summaryrefslogtreecommitdiffstats
path: root/src/common/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/common/CMakeLists.txt')
-rw-r--r--src/common/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/src/common/CMakeLists.txt b/src/common/CMakeLists.txt
index b7c15c191..a12edc584 100644
--- a/src/common/CMakeLists.txt
+++ b/src/common/CMakeLists.txt
@@ -37,6 +37,7 @@ add_library(common STATIC
cache_management.cpp
cache_management.h
common_funcs.h
+ common_precompiled_headers.h
common_types.h
concepts.h
div_ceil.h
@@ -95,6 +96,7 @@ add_library(common STATIC
param_package.h
parent_of_member.h
point.h
+ precompiled_headers.h
quaternion.h
reader_writer_queue.h
ring_buffer.h
@@ -183,3 +185,7 @@ else()
target_link_libraries(common PRIVATE
$<IF:$<TARGET_EXISTS:zstd::libzstd_shared>,zstd::libzstd_shared,zstd::libzstd_static>)
endif()
+
+if (YUZU_USE_PRECOMPILED_HEADERS)
+ target_precompile_headers(common PRIVATE precompiled_headers.h)
+endif()